Skip to content

Commit

Permalink
bagger-exports: add 0.0.9
Browse files Browse the repository at this point in the history
  • Loading branch information
zegeek committed Jul 29, 2024
1 parent c8af8fd commit ccc6b97
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 1 deletion.
3 changes: 2 additions & 1 deletion dev-db/bagger-exports/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bagger-exports-0.0.7.tar.gz 8922 BLAKE2B 3d7feed46f1b4c2cc7e86d25679b76f2d271708e2af4e50183021f31cdb770efd02e76a00c070ebad5667bedbb60185275fbcf0727b2c02bdd9d299b2a860ffe SHA512 8329b04effe49961d0af5e24c158ed22a189938d9a896edcec8829635cced3b007f5ed18b49f3f389a446a221adda98fe7a30fb7697c07fe70a3be29911744a6
DIST bagger-exports-0.0.8.tar.gz 16168 BLAKE2B ed0c3c33445fec791ba6ba48df183fa408a5f5257c2123e4d04644a3fee62c057bc13950ba5d404dd4280c964ba326f8be7375c2a9d93113d81387de48bd3e65 SHA512 bd9880c44a1d74aa47dbc7c042963eb1eaeafd2b3e43168f05a251376ec4071c408d2da7c81e750319a4e24fce0d6adbc9881f3867fa3909e5df57d23b8a1641
DIST bagger-exports-0.0.8.tar.gz 16168 BLAKE2B ed0c3c33445fec791ba6ba48df183fa408a5f5257c2123e4d04644a3fee62c057bc13950ba5d404dd4280c964ba326f8be7375c2a9d93113d81387de48bd3e65 SHA512 bd9880c44a1d74aa47dbc7c042963eb1eaeafd2b3e43168f05a251376ec4071c408d2da7c81e750319a4e24fce0d6adbc9881f3867fa3909e5df57d23b8a1641
DIST bagger-exports-0.0.9.tar.gz 22291 BLAKE2B 32c6065e46cb111b515eff46985861d547de9e50187d469285fc54cb813c2208abc0f6d9394eb9dbd21c658b788a63e535244c9f01f0c4c0317dfc139cd62298 SHA512 6dc06dcad4919affe3a41d19db66d0c8cacf7f6075cfa747fe833cb300f297982c1fd9142eb9a472fa7127edf8281920344c73e622e2e1b0dd6b72b7db5aedde
57 changes: 57 additions & 0 deletions dev-db/bagger-exports/bagger-exports-0.0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

POSTGRES_COMPAT=( "10" "11" "12")

inherit postgres-multi vcs-snapshot

DESCRIPTION="adjust bagger json exports extension"
HOMEPAGE="https://github.com/adjust/bagger_exports"

# We do this package name dance to reuse the tarball from bagger-tools
SRC_URI="https://github.com/adjust/bagger_exports/archive/v${PV}.tar.gz -> bagger-exports-${PV}.tar.gz"

LICENSE="Unlicense"
KEYWORDS="~amd64"

SLOT="0"

IUSE="+schaufel"
RESTRICT="bindist fetch"
LICENSE="Unlicense"

DEPEND="
"

RDEPEND="
${DEPEND}
${POSTGRES_DEP}
schaufel? (
>=app-admin/schaufel-0.9
)
>=dev-lang/perl-5.26
"

pkg_nofetch() {
[ -z "${SRC_URI}" ] && return

# May I have your attention please
einfo "**************************"
einfo "Please manually download"
einfo "$SRC_URI"
einfo "and put it on binhost"
einfo "**************************"
}

src_unpack() {
default
mv "${WORKDIR}/bagger_exports-${PV}" "${WORKDIR}/${P}" \
|| die "Renaming src dir failed"
}

src_install() {
postgres-multi_src_install
dobin "${WORKDIR}/${P}/scripts/"*
}

0 comments on commit ccc6b97

Please sign in to comment.